How to update on My android

Comments

1 comment

  • Avatar
    WB Gamer

    Hi! GoT: Conquest requires Android version 6.0 and up. 

    Please check your device settings for an update to your Android platform (Settings > System Updates> Check for Updates).

    If your issue persists please submit a ticket to Customer Support at https://hbogamessupport.wbgames.com/hc/en-us/requests/new and an Agent will be happy to assist you.

    I hope this helps!

    Stalan

Please sign in to leave a comment.